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Installation

System Requirements

The aRTist program comes as a Microsoft Windows application. The system requirements narrow
down to the required platform: Microsoft Windows 7 or superior. The program is provided as 64-bit
application.

It is possible to use aRTist on low prize netbook hardware. But it is recommended to run it on
computers with multi (core) processor and accelerated graphical processing unit (OpenGL 2.1) to
have the necessary calculation speed for treating ambitious simulation tasks efficiently.

aRTist Licenses

The aRTist program is equipped with software protection mechanisms and needs license activation for
full functionality. Without activation, the program runs in Lite mode of reduced functionality. In case
of licensing errors, e.g. broken license file, the program might still be usable to arrange and review
virtual scenes, but it is not possible to make any simulations (viewer mode).

 An evaluation period of 30 days is granted without any license activation (DEMOMODE).

An aRTist license is shipped as serial number, which can be used to activate an aRTist installation.

 Licenses can be bound to a specific PC (node-locked license) or shared among different
installations (network license).

The aRTist licenses can be used either node-locked or shared within a network. A node-locked license
is assigned to one specific PC. With network licensing the aRTist program can be installed on several
PCs with access to the same license file. In this case aRTist can be alternately used on different PCs
(floating license). To run several aRTist installations at the same time it is possible to assign more
than one license to the shared license file.

Installation instructions

The radiographic simulator aRTist comes with an installation routine ‘aRTistSetup-X.X.X.exe’ (where
X.X.X is replaced by the version number). For installation execute the setup routine you got with your
distribution. A dialog will appear (Figure 1) and guide you through the installation process.

 If aRTist is already installed, the installation routine will ask for de-installation of the current
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version before proceeding with the installation process, if necessary. Consequently, installations
with the same version number will be replaced, while installations with different version numbers
can coexist on the same PC.

During the installation process, you can choose options like the generation of a Windows Start Menu
entry and a Windows Desktop icon for convenient program execution. After installation aRTist is ready
to use. Without an active and valid license aRTist will run with the restricted functionality of
Lite/Viewer mode only.

In the next section you will find information on reqesting a evaluation or permanent license activation.

Fig. 1: Installer welcome screen.

Fig. 2: Installer option selection.

License Activation

aRTist needs to be installed before proceeding with the license activation. The activation is a two-step
process: first, a dedicated activation request has to be sent to the supplier of the software and
secondly, the activated license file provided in response has to be installed.

The actual license status can be displayed by item License Information at the Help menu (Figure
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3).

Activation request

The activation request requires information about your aRTist installation. The necessary information
can be collected at the license information dialog of aRTist (menu bar: Help). There are options to
apply for node-locked or network licensing and to request an evaluation period. E-mail the request to
aRTist@bam.de.

In response to an activation request, you will get back an activated license file within the next
business days.

 To request a network license, a shared network folder has to be prepared in advance. It is
required to store the common license file.

 All users of the network license need to have write permission for the license file.

Fig. 3: License information dialog (menu bar: Help⇒License Information).

mailto:aRTist@bam.de
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License File Installation

The final step to activate a license is to install the license file provided in response to the activation
request. Generally, this means overwriting the temporary license file by the activated one.

The license file installation can be done just by opening the license file in aRTist.

 Just Drag'n'Drop the license file over the aRTist window to install it.

 The same applies to use an already activated network license at additional PCs: Just
Drag'n'Drop the license file at the network folder over aRTist window. Complete the subsequent
dialog “Use (not install) this network license?” with “Yes”.
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Getting Started

This manual describes how to operate the aRTist software package for computer simulation of
radiographic testing.
The first chapter Getting Started will give you a short overview of the user interface with its different
areas.

User Interface

The aRTist user interface, the main window, includes the following areas:

Menu bar
Toolbar
Parameter panel with tabbed pages of modelling settings (left)
Virtual scene, a 3D scene view of the radiographic setup (right of parameter panel)
Docking area to integrate additional program windows within the main window. By default, the
ImageViewer showing the simulated radiograph is placed here (right or bottom, configurable).
Status bar (bottom)

Figure 4 shows the default view of the user interface. The scene already contains two items: source
and detector. The three main areas (Parameter Panel, virtual scene, docking area) can be scaled by
clicking and dragging the edges of the respective areas.

Fig. 4: User interface
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Menu Bar

The Menu Bar is a horizontal “bar” anchored to the top of the screen (Figure 5). It consists of different
drop-down menus and contains generally known commands like Save, Copy or Undo and program-
specific commands to adjust and modify the assembly. A black tick next to an option indicates that it
is currently activated: .
Further information regarding the Menu Bar can be found in the separate chapter.

Fig. 5: Menu bar

Toolbar

In the toolbar you can find some of the menu bar commands for easy access (Figure 6). All of those
commands indicated by its toolbar icons will be explained in the Menu Bar section of this guide. The
toolbar can be found directly below the Menu Bar and contains icons, some of which have a drop-
down menu that can be opened by clicking and holding for a second or with a right-click. Hover over
an icon with the mouse pointer and a little tag with a short explanation of its function will appear. An

activated icon can be identified by a black border around the symbol: . While a deactivated icon

does not have one:  (The highlighting of selected checkbuttons may depend on OS version and
settings).

You can hide the toolbar by clicking on Toggle Toolbar Visibility at the View menu.

Fig. 6: Toolbar

Parameter Panel

The Parameter Panel on the left contains four tabs: Setup, Source, Scattering and Detector (Figure 7).
Each tab offers several options to modify parameters of the simulation. You can rotate, translate or
scale the items of your assembly list, make adjustments to the source and the detector or take
scattering into account. Hide/Show the Parameter Panel by clicking on Toggle Setup Visibility in the
View menu or by pressing Ctrl-w on your keyboard. Further information about the Parameter Panel
can be found in the separate chapter.
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Fig. 7: Parameter Panel

Virtual Scene

The 3D visualization area shows the virtual scene view, a 3D representation of the setup (Figure 8).
The default view only contains source and detector. In the assembly, virtual parts (geometric objects)
can be appended in the scene view. The virtual scene can be freely rotated, scaled and shifted in
space in the following ways:

Hold down the left mouse button over the empty space of the scene view and drag it. The scene
will rotate.
Hold down the right mouse button and drag. The scene view will scale.
Hold down the middle mouse button and drag. The scene view will move with the mouse.

A coordinate system pictogram is shown in the bottom left corner indicating the actual orientation of
the scene view.

In this guide items define all parts, detector and source in the scene. While parts are only the
geometric objects in the scene.

For selecting items in the scene view, use the Ctrl key on the keyboard and click on them with the left
mouse. The first selected item can be recognized by its yellow corners. All subsequent items will be
marked with white corners. The order of selection can be important for Geometry applications.
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Fig. 8: Virtual scene, scene view

Docking Area

In the docking area is written “Place windows here”. Several commands throughout the program open
separate windows (mostly modules) that can be docked in the docking area (indicate to chapter →
Modules). You can minimize or close a window from the docking area or (un)dock it by clicking on the
blue pin between the minimize and close symbols: . An undocked window can be relocated
anywhere on the user surface. The default docking area contains only one window, the ImageViewer,
which displays the radiograph according to the assembly. You can hide the docking area by clicking
on Toggle Dock Visibility in the View menu or by pressing Ctrl-d on your keyboard.

Status Bar

The status bar at the bottom of the user interface displays information when hovering over certain
areas with the mouse pointer (for example the ImageViewer or the scene view) or when a calculation
is finished (Figure 9).

Fig. 9: Status bar

General Simulation Approach

When you first start up aRTist, you will see the screen as in Figure 4. If you make any mistake, you

can use the undo icon  in the main toolbar.
In the following, the general approach for a successful radiographic simulation with aRTist will be
explained.
First of all, you need a part in the scene, which you want to image. The detector and source are
already available.

http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Agetting_started&media=artist:undooo.png
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Click on the Open library icon  or on the Solid icon  in the main toolbar and choose
a part or project (in library).

The part appears in the scene center, and a new entry appears in the Assembly List of the
Parameter Panel → Setup (see Figure 10, left side).

To move the part you have to select the part first by clicking on it in the scene (recognized by
its yellow corners) or by selecting it in the Assembly List (highlighted blue). An arrow shows the
manipulation axis.

The Transformation settings of the part can be done below the Assembly List (Figure 7). You can
select each axis by clicking on the axis button arrow. Type the Value or use the arrows next to
it.

The Transformation buttons allow to choose between world coordinate system (world button)
and local coordinate system (house button). Choose a button next to it to rotate, translate or
scale the part. The part can be moved with the slide control or directly in the scene with the left
mouse button. You can monitor the movement/modification of Reference position, Position,
Orientation and Size over the display fields in the bottom of the Setup page. You can
alternatively type the values yourself. A big axis with a red ball at the original position appears
when you translate the part. This ball indicates the reference point. It is used as the center
when a part is rotated.

If you want to move the source and/or detector just select the item and transform analogically.

In the Assembly List you can change the material of the selected part of the scene. The part is
made of iron as a default. Click on the corresponding column and a drop down box will appear,
where you can select desired material. (similar for Display → changing the Opacity)

The standard detector has only a resolution of 100×100 pixels. These settings can be changed
on the Detector panel (see Figure A of Tab. 1). Therefore click on the notebook header Detector
of Parameter Panel. At the top of the panel, in the Geometry frame, there are fields with
physical size of the detector, the size of a single pixel and its pixel resolution (Res.). In
Characteristic frame you can select the detector type.

The standard scene is equipped with a 150 keV monochromatic source. The source setting of
the X-ray tube can be changed in the Source panel (see Figure B of Tab. 1). In the top frame
labeled Source spectrum is a graph of the spectrum with a single line at 150 keV. Click on the X-

ray tube icon  to open the spectrum calculator. There you can select the General tube to
have a typical Bremsstrahlung spectrum in the spectrum graph and set the parameters like in
the screenshot of Figure C (Tab. 1). Press Compute when your settings are set. You also can set
the current in the Exposure. Open the drop-down list under Spot type and make a selection.
aRTist can consider an extended source focal spot and computes multiple rays per pixel of the
final image.

Choose the Zoom to selection icon  in the main toolbar to see where the axis goes
through. To see the full scene again, click in the empty space of the 3D view to deselect all
parts. Then again, click the Zoom to selection icon.

On the right side of Figure 10, the ImageViewer displays the preview image of the simulation

http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Agetting_started&media=artist:lib.png
http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Agetting_started&media=artist:icon-solid.png
http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Agetting_started&media=artist:xray-tube.png
http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Agetting_started&media=artist:zoom-select.png
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(identify by the crossed out red circle: ).

Click on the Run icon  in the main toolbar to display the finished simulation in
ImageViewer (identify by a green tick: ).

If your radiographic setup is finished, you should save your work as a project file. Click the Save

icon  in the main toolbar. Choose “aRTist Project” as the type and save your settings.
aRTist stores everything inside the project file including the CAD files. This means you can pass
the project around to colleagues who will be able to open and reproduce your simulations.

Fig. 10: Screen of aRTist program, one part added into the scene

Tab. 1: Table for General Simulation Approach

http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Agetting_started&media=artist:red_circle.jpg
http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Agetting_started&media=artist:run1.jpg
http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Agetting_started&media=artist:green_tick.jpg
http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Agetting_started&media=artist:save.png
http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Agetting_started&media=artist:dog22.png
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Parameter Panel Detector settings

(A)

Parameter Panel Source settings

(B)

Spectrum calculator

(C)

http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Agetting_started&media=artist:det.png
http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Agetting_started&media=artist:quelle.png
http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Agetting_started&media=artist:gg.png
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Menu Bar

The Menu Bar consists of different drop-down menus with common Windows commands and program
specific functions (Figure 11) that will be explained in this section. Some of the menu entries can also
be found in the toolbar indicated by the same icon. If that is the case, the icon is next to the
command/option in this manual.

Fig. 11: Menu bar

File

The “File” drop-down menu comprises commands referring to the current project (Figure 12).

Fig. 12: File Menu

New Project opens a new aRTist scheme. This may also be done by pressing Ctrl-n. The program will
ask you, if you want to save the changes on your current project.

 Open is used to search an existing project. Then select a project file in the dialog boxes that
follow. Otherwise press Ctrl-o.

 Open Library is used to make a selection in the register of files. There example parts and
projects can be found. It can also be opened by pressing Ctrl-l.

 Save the current project to a single file. Alternatively press Ctrl-s.

Save as renames a project or changes the location of where you want to save it. By pressing Ctrl-
shift-s the command Save As will be opened, too.

Reload External Files serves to check and update external dependencies (incorporated data files)
of the current project. There you can choose file versions from the project or the file system in the
dialog box that follow.

Last Directories shows a list of recently opened directories. By clicking on an entry, a file open
dialog for this directory will pop up.
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Open New Window starts a new aRTist in addition.

Restart reboots the programm. Before restarting, the program will ask you if you want to save the
changes on your current project.

Quit terminates the program. Before quitting the program will ask you, if you want to save the
changes on your current project. This will also be achieved by pressing Ctrl-q.

Edit

The “Edit Menu” contains undo/redo functionalities with the projects history, whereas the usual
commands (cut, copy, paste and delete) refer to parts in the assembly (Figure 13).

Fig. 13: Edit Menu

 Undo erases the last change done to the project reverting it to the last state it was saved as.
The program will also be undone by Ctrl-z.

 Redo reverses the Undo or advances the buffer to its former state. Otherwise press Ctrl-y. The
opposite of Undo is Redo. The Undo and Redo commands restrict you to an incremental sequence of
changes.

History displays the report of the edit and lets you revert back to any previous change instantly. By
pressing Ctrl-h the program will open the history, too.

 Cut removes parts from the assembly and keeps it in the clipboard. Therefore select part(s) you
want to cut by using the Ctrl key on the keyboard and click on them with the left mouse either in the
scene or in the Assembly List (of Parameter Panel).

 Copy can create a duplicate of the part. First, select part(s) you want to copy by using the Ctrl
key on the keyboard and click on them with the left mouse either in the scene or in the Assembly List
(of Parameter Panel). The selected parts are kept in the clipboard.

 Paste appends parts in the clipboard to the Assembly List, again.

 Delete removes selected parts from the Assembly List.
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Geometry

The “Geometry Menu” includes all functions regarding the geometry application for parts from the
assembly (Figure 14). Especially “Geometry Manipulation” (→ Union, Intersection, Difference, Arrange
and Pick Destination) for creating and arranging more complicated parts are described more in-depth
in the separate chapter.

Fig. 14: Geometry Menu

 Center New Parts position new parts while loading from external files (.stl or .ply) at the origin
of the global coordinates, if activated. If deactivated, new parts will be loaded with its original
position.

Isolate deactivates all parts in the scene except the selected ones. Alternatively you can deactivate

or activate a part with a click on the eye symbol  at Parameter Panel → Setup → Assembly List →
Activate/Deactivate option.

Activate/Deactivate selected item(s) of the assembly. If you deactivate an item, it will be ignored
during simulation and be nearly invisible in the scene. Please note, that you have to mark the
respective item first. Otherwise you may use the eye symbol in the Assembly List of the Parameter
Panel to achieve the same effect.

Set Material changes the material of a selected part. As an alternative, you may click on the
material name of a part in the Assembly List of the parameter panel to open a drop-down menu with
the same options.

Union/Intersection/Difference is used to create complex parts in the scene. For the commands
Union, Intersection and Difference, parts have to be created (e.g. with Solid module) and placed in the
scene, so that they overlap. Then, select parts by using the Ctrl key on the keyboard and click on
them with the left mouse. The first selected part can be recognized by its yellow corners. All
subsequent parts will be marked with white corners. The so-called Geometry Manipulation commands
are explained simplified in the subsequent.

Union joins two or more parts. Thereby the order of selection is not important.

Intersection creates a new part from the overlapping areas of at least two parts. Everything else will
be removed. The order of your selection is not important.
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Difference is used to create a new part from the difference of at least two other parts. By selecting
this command the order of selection will be important for the result. The first selected part (yellow
corner) is thereby the minuend and all other selected parts (white corners) are the subtrahends.

 Arrange is used to put parts in order to the assembly. Select the parts, which have to be
arranged, and activate this command. With the opening dialog box four options: none, -, center, + are
available for each of the three axes. The parts will be aligned with the first selected part.

Pick Destination moves item(s) from one point of the scene view to another. Click with the left
mouse on desired destination to relocate selected item(s).

Compute

The “Compute Menu” offers different enable/disable functions referring to view attributes in
ImageViewer, intern computations and the Run button for starting simulation (Figure 15).

Fig. 15: Compute Menu

 Run starts a simulation of the current assembly. Resulting images are presented in the
ImageViewer.

Radiography/Thickness maps is used to display grey values or thickness maps in ImageViewer.
You may choose between these two options to either simulate radiography (ImageViewer displays
grey values) or thickness maps (ImageViewer displays thickness in mm for each material of the
assembly list and of the environment). Otherwise, you may use the Run toolbar icon by opening its
drop-down menu: click and hold for a second or click with the right mouse button.

Use GPU accelerates computation if activated. Thereby the computers GPU will be used alongside
CPU.

Single Precision uses the available storage space more efficiently (when a check mark is next to it).
The figures or calculations are thereby less precise. Where in the opposite of the so-called “Double
Precision” (= inactive single precision, without a check mark) the computations are more precise with
more decimal places.

  Render Previews enables/disables live rendering of preview images in ImageViewer.
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Modules

Different modules in this drop-down menu are available for several functional simulations. More
information about the modules (Figure 16) can be found in the separate chapter Modules. All modules
can be docked in the docking area or be handled as separate windows. In the following you can find
short introduction information about the single modules.

Fig. 16: Modules Menu

Manage Modules

In the Mange Modules individual modules can be selected, which will load at startup of aRTist. The
changes take effect at the next startup.

DetectorCalc

The DetectorCalc module is useful to create a new detector with specialised settings for flat panel
detectors. Thereby the reference shot is necessary for calibration and calculation, also filtration over
the detector is possible.
For more information see the chapter Modules → DetectorCalc.

CtScan

A simulated computerized tomography (CT) scan is enable with the CtScan Module. It combines series
of X-ray images taken from different angles and uses computer processing to create cross-sectional
images or slices of a part. CT scan images provide more detailed information than plain X-rays do.
In the three tabs of this module the corresponding settings can be navigated. Click on the Run button
in the bottom of each page to start the simulation or to stop it. When the simulation is finished, click
on the Show button of the first tab and the tomogram can be viewed in the scene. In ImageViewer the
sectional image of the tomogram can be seen when in Volume View (third tab of CtScan Module) the
Show button is clicked. For more details see in Modules → CtScan.

http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Amenu_bar&media=artist:neu_module.png
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DigRad

This module will add new detector descriptions to aRTist. It is intended to describe individual digital
detectors by measured values according to system characterization standards. For more information
see Modules → DigRad.

ImageViewer

 The only module by default in the docking area is the ImageViewer. The preview image and the
finished simulation are displayed there. You may choose between radiography and thickness map.
The different settings and functions of ImageViewer (upper bar, lower bar and bar on the right) will be
explained in Modules → ImageViewer. In a subitem called Tools Menu: ImageViewer advanced settings
from the Menu Bar → Tools → ImageViewer are described.

LogViewer

The LogViewer displays messages generated by aRTist and its components.

McRay

McRay is a Monte Carlo raytracing implementation of electron and photon transport. This module
forms a graphical interface for McRay, in order to configure and run simulations using it from within
aRTist. The McRay module consists of six tabs: Basic, Advanced, Expert (including: General, Photons,
Electrons, Scene, Detector, Spectrometer, Objects), Manual, Cluster and Interactive. A Run/Stop
button is at the bottom of each tab. The different settings and functions of McRay will be explained in
Modules → McRay.

Solid

 With the Solid module, simple parts (respectively virtual objects) of different sizes can be
created and added to the scene. Different geometric shapes can be chosen from: cuboid, ellipsoid,
cylinder, tube, cone, text, wedge and/or step wedge. For more information see the chapter Modules →
Solid.

TomoSynth

Simulating tomosynthesis within aRTist are enabled with the TomoSynth module. On the
Laminography tab settings for the tube, detector and output options can be set up. The Advanced tab
offers settings for experts. More functions and information of TomoSynth will be explained in Modules
→ TomoSynth.
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Tools

The “Tools” drop-down menu offers several help-functions relating to error messages (Console, VTK),
irradiation settings (attenuation data, detector properties, ImageViewer) and settings for materials or
spectrum (Figure 17). A detailed description about the tools topics Attenuation Data, Detector
Properties, Materials, Spectrum and Settings can be found in the separate chapter Tools of this
tutorial.

Fig. 17: Tools Menu

Show Console

This will open a console window to the command-line interface of aRTist. Here detailed status
information is available. Additionally, it allows to control aRTist by commands in Tcl/Tk scripting
language. The menus from the Console menu bar are also accessible with a right-click anywhere on
the surface of Console (Figure 18).

Fig. 18: Console
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Show VTK Log

That command opens the LogViewer of the Modules.

Opening Angle

This command shows the actual opening angle of the cone beam of the source in the Status Bar
(Figure 19).

Fig. 19: Status Bar indicates the Opening Angle (left)

Attenuation Data

Attenuation Data opens the AttenuationViewer, which displays attenuation-coefficient graphs as a
function of the radiation's energy. A more in-depth explanation can be found under Tools →
Attenuation Data.

Detector Properties

Detector Properties opens the DetectorViewer, which contains plots of the properties of the current
detector.
Further information can be found under Tools → Detector Properties.

ImageViewer

This ImageViewer submenu of the tools menu is (for technical reasons) the access point to the menu
of the ImageViewer. Therefore this topic ranks to the Modules → ImageViewer → Tools Menu:
ImageViewer, where more information can be found. The submenu of the ImageViewer offers several
commands for the current image/simulation. Please note that changes made with commands from the
Image submenu are permanent (for example when saving the image). For non-permanent
modifications use commands in the View submenu.

Materials

 With the Materials editor all materials that are available within aRTist including density and
composition are listed. It is possible to edit materials and to dock the editor in the docking area. For
more information see: Tools → Materials.

Spectrum
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Specific settings for the source can be adjusted by the Spectrum calculator. These settings can also

be opened from the Parameter Panel → Source: . In the separate chapter Tools under Spectrum
you can find more explanations about these settings. The Spectrum calculator can be docked in the
docking area.

Settings

The Settings dialog box offers several options for the user interface. It should not be altered usually.
Under Tools → Settings more information can be found.

View

This drop-down menu offers various different settings related to the point of viewing the scene and
toggle functions for the items in the Assembly List (Figure 20).

Fig. 20: View Menu

 Zoom to selection enlarges to a previously selected sector of the scene.

 Default view retrieves the standard perspective.

 View along X/Y/Z chooses either one of these options to view the scene along
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different axis (X, Y, Z).

 Pick focal point is used to select a different focal point in the scene.

 Orthographic projection shows the assembly in the scene view as an orthographic projection
when activated as opposed to a perspectival view. It can be helpful when you align the components of
the assembly.

 Toggle Axes displays the local coordinate system of a selected item in the assembly (Figure
21).

Fig. 21: Scene view showing an ellipsoid with its axes

 Toggle Bounding Box displays the bounding box of a selected item in the assembly (Figure
22).

Fig. 22: Scene view showing an ellipsoid with its bounding box

Toggle Edge Visibility displays in black the edges of the triangles forming a specific item in the
assembly (Figure 23). It can also be activated/deactivated by pressing e on the keyboard. It has only
an effect if Toggle Wirframe is deactivated.
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Fig. 23: Scene view showing an ellipsoid realized with edge of the facets

 Toggle Wireframe displays a wire-frame model of a selected item in the assembly (Figure 24).
The item will be transparent. As an alternative it can also be activated/deactivated by pressing w on
the keyboard.

Fig. 24: Scene view showing an ellipsoid in wireframe mode

Multiple Views show the assembly from three different angles in the upper sector of the scene view
(Figure 25).

Fig. 25: Multiple Views

Views follow main camera refers to the previous one and only has an effect if both are activated. If
acivated, multiple views will follow main camera when the scene is being rotated.

Show source cone enables/disables the display of the beam cone originating from the source
(Figure 26).
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Fig. 26: Scene view showing the source cone

Show orientation activates/deactivatea the display of the coordinate system in the bottom left
corner of the scene view.

Stereo rendering activates/deactivates stereo rendering in the scene (Figure 27).

Fig. 27: Scene view showing stereo rendering of the items

Fullscreen displays a fullscreen version of the program's user interface. Deactivate the option to
retrieve normal view.

 Toggle Toolbar/Dock/Setup Visibility is used to hide the toolbar, docking area or Parameter
Panel. Docking area and Parameter Panel can also be toggled by pressing Ctrl-d and Ctrl-w
respectively.

Help

This drop-down menu provides some help options and license information.

Fig. 28: Help Menu

 Show Inline Help depicts the inline help where available, e.g. at Scattering, or materials.

http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Amenu_bar&media=artist:artist-menuhelp.png
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Homepage opens aRTists homepage at http://artist.bam.de/ .

User Guide opens the documentation file (PDF).

License information gives you the actual license status and. See also Installation → aRTist Licenses.

About aRTist opens the about box where you can find information about the program, the installed
version, installed modules and third-party software.

http://artist.bam.de/
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Parameter Panel

The Parameter Panel on the left contains four tabs: Setup, Source, Scattering and Detector. It offers a
number of settings for the essential segments of a radiographic assembly to help you create a
realistic radiographic simulation.

Setup

The “Setup” of Parameter Panel is mainly pertinent for positioning items in the assembly.

Default settings (Figure 29):

Environment: air
world coordinate system
translate mode

Fig. 29: Parameter panel: Setup

Environment
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Open the drop-down menu and select an environmental material of your choice. This material applies
everywhere at the space of the scene outside of any part.

Assembly list

The Assembly List consists of five columns (Figure 30). You can select an item from the assembly
either from the list or the virtual scene. Use therefore the Ctrl key on the keyboard and click on them
with the left mouse. It will be highlighted blue in the list and marked with yellow corners in the virtual
scene. All subsequent items in the scene will be marked with white corners.

Fig. 30: Environment, Assembly List

ID represents an unique identification for an entry.

 Deactivates/Activates an item with a click on the eye symbol. Alternatively, you may use
the corresponding commands from the Geometry menu.

Name changes the name of the part (by double-click). It is not possible to change the name of
the detector and source.

Material changes the material of a part (by double-click). Here it is not possible to change the
material for detector and source.

Display shows the color and opacity of each item. Double-click on the number to change the
color and opacity.

Transformation

Under transformation you can find a number of options to manipulate and scale each item of the
Assembly List (Figure 31). Proceed in the following way:

1. Select an item.

2.  Choose between world coordinate system and local coordinate system.

3.  Choose type of transformation: rotate, translate or scale.

4.  Select an axis or all three with a click on one of the green
arrows. 0 = axis is currently not selected, 1 = axis is currently selected.

5.  Set the step size with the green arrows or type in a value. The unit matches the type of
transformation: degree, mm or 10 % magnification.
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6.  Rotate, translate or scale the item with the slide control or directly in the scene with the left
mouse button. You can monitor the movement/modification of Reference position, Position,
Orientation and Size over the display fields in the bottom of the Setup page and also put in values
yourself as an alternative to the previously explained approach.

Fig. 31: Transformation of an item

Source

The “Source” tab of Parameter Panel is important for defining the radiation source settings.

Default Settings (Figure 32):

point source
voltage: 150kV
graph
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Fig. 32: Parameter panel: Source

Source Spectrum

The main area of this page displays the source spectrum (Figure 33).
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Fig. 33: Source spectrum

Top:

 Save spectrum graph or data as a .txt file.
Choose between graph or text via tabs

Bottom:

Enable/Disable log x, log y, Lines, Grid via checkboxes.

 Load spectrum from aRTists library. You can choose from four different spectra: Co-60,
Ir-192, Se-75, Yb-169.

 Save current spectrum as a .xrs file.

 Calculate x-ray tube spectrum opens the Spectrum calculator where you can make detailed
adjustments to the tube. Important details of the current tube settings are displayed directly
above the Graph/Text tabs. A more in-depth explanation of the spectrum calculator can be
found in the Tools → Spectrum section of this tutorial.

 Show current spectrum opens the current spectrum in a seperate window. Click and hold
for a second or right-click for more options (Show original spectrum, Show reduced spectrum or
Show preview spectrum).

 Plot attenuation data displays the attenuation data for the current settings. In the separate
section of this tutorial Tools under Attenuation Data more information can be found.

 Show attenuated spectrum for picked position opens the Spectrum Picker. The incident
beam is shown in black, the attenuated beam in blue (Figure 34). You can dock the window in
the docking area.

Fig. 34: Spectrum Picker

 Pick image position to calculate attenuation for is used to pick a spectrum reference position
in ImageViewer (click with the left mouse button and hold). Alternatively, you may put in the X-
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and Y- coordinates manually. The beam shown in Figure 34 is attenuated by an aluminum cube.

 Save current data as a .txt file.

 Recalculate attenuation data

Exposure

Enter the tube current in mA, or the activity in GBq if you want to use a radionuclide (Figure 35). Open
the Activity calculator ( ) to determine a actual activity from a reference activity in the past.

Fig. 35: Exposure by radionuclide

Activity Calculator

 Pick reference and exposure dates - « »: year, < >: month. To enquire the
present-day activity, you may simply press the Today button in the lower part of the window.

Put in activity in [GBq] or [Ci] and halflife in [s]. You may also convert to the respective
alternative unit.

Press Set to apply changes.

Fig. 36: Activity Calculator

Focal spot

Select number and arrangement of focal spot samples from the list or enter your own values (Figure
37). A single integer denotes the number of samples randomly distributed by poisson disk sampling
algorithm (weighted by focal spot image if this has been set). An entry of the form NxM denotes a
regular grid. Geometric unsharpness is negligible. A 5 point source is sufficient to check for possible
unsharpness.
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X, Y: Size of focal spot along X, Y in [mm]. Attention: This is the overall size, or extent, of the focal
spot. If a profile image is used, the effective spot size may be smaller.

Fig. 37: Focal spot settings

 Create a spot profile image opens the Focal Spot Profile dialog box.

Set the Focal Spot Profile (Figure 38):

effective spot width in mm, FWHM of horizontal profile
effective spot height in mm, FWHM of vertical profile
Lorentz fraction of pseudo Voigt profile, 0.0 … 1.0
pixel dimension of spot profile image (Resolution)

Fig. 38: Focal Spot Profile settings

 Load spot profile image from file: Supported files: .tif, .tiff, .raw, .bin, .fld, .png, .bd, .dd.

 Delete spot profile image

 Show spot profile image

Scattering

The “Scattering” tab of Parameter Panel is useful for different scattering settings (homogenous,
McRay etc.) in the stimulated radiation.

Default settings (Figure 39):

Mode: off
Reference point: min
Set defaults: ✔
# of photons: 2e+007
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Fig. 39: Parameter panel: Scattering

Parameters

Mode

off does not take into account scattered radiation at all.

build-up factor is used to estimate a constant scatter. The build-up factor is the ratio of total to
primary radiation at the reference position.
Decreased contrast due to scattering is simulated. Set the build-up factor in the build-up B input field.
Build-up factor of 2 means as much scatter radiation (S) as primary radiation (P) impinges on the
detector at the reference position.

 BuildUp Estimator estimates the BuildUp Factor for a specific part. You can dock the window in
Figure 40 in the docking area.

Set material and thickness in mm, the number of layers and the energy resolution in keV
Enable/Disable multiple scatter
Press Update (BuildUp factor will be estimated but not set) or Set

Layers, Energy resolution and Multiple Scatter are model parameters for the algorithmus function
thereby. Material and Thickness are physical parameters for the geometric function. After the
program restarts with a build-up factor additionaly primary + scatter intensities can be seen in
ImageViewer.
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Fig. 40: BuildUp Estimator settings

external file is used for a user-supplied image, which is scaled and added. The corresponding primary
radiation at the reference position has to be set (→ file primary intensity).

McRay is used to determine the amount of scattering with Monte Carlo simulation. It calculates fully
automatic the Monte Carlo of scatter contribution. A larger number of photons results in a better
estimate, but longer calculation times.

Reference Point

Select the reference point within the detector image. Available settings:

Off is used to set a value under ref. primary intensity, instead of using a reference point.

Min selects the image point of minimum grey value as the reference.

Max selects the image point of maximum grey value as the reference.

Center selects the image center as the reference point.

Picked is used

 to pick a scatter image reference point in ImageViewer (click and hold) or

 to put in the X and Y coordinates manually.

   : Load, delete, show or smooth scatter image.

McRay - Monte Carlo ray tracing

Monte Carlo ray tracing (Figure 41) will contribute a image of scatter radiation based on the actual
setup. This includes considerable extra computing effort. Typically, it takes seconds to minutes for
one calculation. Worthwhile when inspecting castings (thick walls). Build-up factor is recommended
when inspecting metal sheets and welds. More detailed settings for McRay can be done in the Menu
Bar → Modules → McRay.

Load result as external file
Use original Image size
Set Defaults
# of photons
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When McRay is finished in the upper bar of the ImageViewer module not only Energy density (J/m²)
and primary intensities can be seen but also scatter intensities and primary + scatter intensities.

Fig. 41: Monte Carlo ray tracing

Detector

The “Detector” tab of Parameter Panel is relevant for the settings of detector properties like geometry
and type.

Default Settings (Figure 42):

Size [mm]: X = Y = 100 mm (square)
Multisampling: source dependent
Curvature: off
detector type: 1:1
reference point: max
set to [D or GV]: 50000
# of frames to average: 1
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Fig. 42: Parameter panel: Detector

Geometry

Fig. 43: Geometry settings

In this part of the Detector tab, you can adjust the geometry of the detector (Figure 43). Choose
which quantity you want to update automatically (Size [mm], Pixel, Resolution [mm]) and set the
values for X and Y. With the button next to the input fields you can predetermine a square pixel area.

Multisampling is used for anti-aliasing. The default setting is source dependent, which means, that
the source's sampling pattern will also be used for the image resulting in reduced computation time.
The other available patterns of the list are: 5, 10, 20, 30 and 1×1, 2×2, 3×3, 4×4, 5×5. Thereby you
can also enter your own values. A single integer denotes the number of samples randomly distributed
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and an entry of the form NxM denotes a regular grid.

Curvature is used to have a curved detector around its reference point along the selected axis
(reference point of the detector should not be the same as its position, but e.g. the center axis of a
cylindrical part). This can be useful if you want to test curved parts like a pipeline. Thereby you can
choose between X or Y curvature.

Characteristic

Fig. 44: Characteristic settings

Detector type is used to select the type of detector you want to use in your simulation. You may
choose between

different types of film (film D4, film D5, film D5 (Ir 192), film D7, film IX100, film IX50, film IX80)
two imaging plates (ST-VI Dynamix SK708, UR-1 Dynamix SK 708)
a flat panel detector
an Air dose meter
an 1:1 detector type
10000:1 (4IC), 10000:1 sharp noisy or
load an external file (External)

To access the digital detector open the DigRad module (Modules → DigRad). The default setting for
detector type is 1:1, which means a 1:1 conversion of dose values into grey values.

For example it is possible to load (in External) saved detector files, which were done with the
DetectorCalc module (Modules → DetectorCalc).

Scan mode takes digitization of film into account. The drop-down menu is therefore only active when
a film is selected for detector type. Then you can choose between a laser-based (Kodak LS85) and a
CCD (CCD 16bit) based scanner or deactivate (off) the option.

Exposure

Fig. 45: Exposure settings

The following settings are available for reference point:

off sets the exposure time in seconds or as hh:mm:ss in the corresponding input field and the
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number of frames to average below.

min sets the exposure time automatically for minimum grey value. Set dose or grey value to
achieve at the reference point (set to [D or GV]).

max sets the exposure time automatically for maximum grey value. Set dose or grey value to
achieve at the reference point (set to [D or GV]).

center sets exposure time automatically for medium grey value. Set dose or grey value to
achieve at the reference point (set to [D or GV]).

picked picks auto-exposure reference point either through manual input of the X and Y
coordinates in the corresponding fields (picked position) or by selecting a position in
ImageViewer (activate access with this button: ).

set to [D or GV] sets dose or grey value to achieve at reference point if possible.

# of frames to average sets the number of frames to average.

Parameter Override

Fig. 46: Parameter Override settings

If the command is selected it is necessary to change the number of the parameters for override
(Figure 46):

unsharpness sets the receptor unsharpness in mm.
long range unsharpness sets a greater receptor unsharpness for imaging plates.
noise factor sets  → no noise factor or 1 → noise factor according to characteristic (factor is not
proportionate).

Flat-field correction

Fig. 47: Flat field correction settings

Flat-field correction is part of the calibration procedure of digital detector arrays. It is used to remove
artifacts from 2-D images that are caused by variations in the pixel-to-pixel sensitivity of the detector
and/or by distortions in the optical path. It also removes the shading in the image due to the different
path lengths of the cone beam. For this reason, the flat-field correction is available here in aRTist as
well. The flat-field (“white”) image is generated by an simulation without any parts in the scene. If
there isn't already a flat field image present, it will be automatically generated. (Figure 47).
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 Calculate, load, delete or show the flat field image.
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Modules

In this chapter the modules of aRTist Menu Bar will be explained in detail.
This drop-down menu contains different Modules that can all be docked in the docking area or be
handled as separate windows (Figure 48).

Fig. 48: Modules Menu

Manage Modules

Select the modules you wish to load at startup of aRTist (Figure 49). All changes take effect only at
the next startup. You can activate/deactivate: DetectorCalc, CtScan, DigRad, McRay and TomoSynth.
Modules like ImageViewer, LogViewer and Solid are obgligatory and cannot be deactivated.

Fig. 49: Manage modules

DetectorCalc

The DectorCalc module opens the Detector calculator (Figure 50). It is useful for the detector's flat

http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Amodules&media=artist:neu_module.png
http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Amodules&media=artist:modules_n.png
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panel settings and calculating the captured photons. In addition to the more general DetectorCalc
there is a simplified detector calculator: DigRad.

Fig. 50: Detector calculator, Settings

General Settings

Set the general settings for your new detector:

Name
Pixel size (mm)
Pixel count X
Pixel count Y
Maximum grey value
Grey value quantum (GV)

Sensitivity

Set

http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Amodules&media=artist:artist-detectorcalc-settings.png
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Material
Thickness (mm)
Steps

The amount of Steps are relevant for the layer model. The more steps you set, the more accurate the
simulation will be. Thereby the execution time will increase. Typically two steps will be enough.

Min Energy (keV)
Max Energy (keV)
Signal Type

Filtration

It is possible to add a filtration over the new detector.

 Click on the green button to add a filter (default filter is Al with 1.0 mm thickness).

 Click on the red button to delete a selected filter.
If you want to change the settings of your filtration, click on the corresponding Material or Thickness.
For the Material column you can choose a material of the editor list (Tools → Materials). For Thickness
just enter your desired value (in mm).

The column Active enables to activate (Yes) or deactivate (No) the selected filter. Therefore use the
left mouse button to choose Yes or No.
Press OK to apply or Cancel to quit these settings.

http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Amodules&media=artist:plus.png
http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Amodules&media=artist:rott.png
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Fig. 51: Detector calculator, Exposure

Reference shot

For creating a new detector it is necessary to set reference values. With those, the new detector will
be calibrated (with available detector settings) and considered for calculations.

Set

Spectrum
Current (mA)
Exposure time (s)
Number of frames
Distance (mm)
Long range unsharpness (mm)
Unsharpness ratio (%)
Grey value
SNR unnormalized

http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Amodules&media=artist:artist-detectorcalc-exposure.png
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Afterwards the new detector can be loaded and applied at Parameter Panel → Detector →
Characteristic → detector type → Extern.

CtScan

With the CtScan module, a computerized tomography (CT) scan can be simulated. The module is
accomplished by Feldkamp reconstruction and volume visualization. The simulated projections can be
processed in the same way as experimental CT projections by external reconstruction programs. It is
recommended to use the TIFF file format for easy data exchange in this case.

The CtScan module consists of three separate pages that can be navigated using the tabs at the top
of the window (Figure 52). At bottom of module window, you can find a Run button to start or to stop
the simulation and a progress bar. The first two pages offer settings for the scan and for
reconstruction (aRTist uses the Feldkamp algorithm for reconstruction). The finished tomogram can
be viewed in the scene with the help of the first (Setup) or third (Volume View) tab by clicking on the
Show button. In ImageViewer the sectional image can be seen with the Slice View in the third (Volume
View) tab. All three pages will be explained in detail below.

Setup

Fig. 52: CtScan: General settings

Scan Parameters

Set



aRTist-UserGuide 45/79

DokuWiki @ BAM 8.3 Printed on 2022-06-21 16:59

total angle [°]
number of steps and
angle step size [°].

Output

Choose directory and file type and put in a file name. The file type can be chosen between BAM CT or
TIFFs and 16 bit or float. If fields are left blank they will be filled in automatically. If you wish to start
reconstruction directly after the scan is finished check the corresponding box, Run Feldkamp. You
may set the parameters for Feldkamp on the second page. Press the Run button on either one of the
three pages when finished with the settings. If you choose not to check the Run Feldkamp box before
starting the simulation you may initiate reconstruction manually (see: Feldkamp). Click on the Show
button when the simulation is finished to see the tomogram in the scene. For an improved view
deactivate the part or minimize the opacity (double-click on the number of the object to change the
opacity: Parameter Panel → Setup → Display).

Advanced

Set

Direction is used to choose between clockwise or counterclockwise direction.
Scatter is used to choose between off or McRay scatter-attitude.
Interval [°] sets the interval for using the same scatter image (to save some time by not
recalculating for each projection).

You may also choose to only include selected parts of your assembly in the simulation.

Feldkamp

Set the parameters for reconstruction on the second page (Figure 53). Check the Run Feldkamp box
on the first page to start reconstruction automatically after the necessary data has been acquired.
Otherwise, you may start reconstruction manually by pressing the Reconstruct button in the lower
half of the Feldkamp page.

File name : You may load previously acquired data with a click on the file symbol or use the
recently acquired data.

Enable/disable:

Interpolation
use of GPU

multiple textures
half precision

Output options:

File type: BAM CT, VTK
8bit, 16bit, 32bit, float
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Fig. 53: CtScan: Parameters for reconstruction

Volume View

With the tab Volume View (Figure 54) it is possible to show sectional image of the finished tomogram
in ImageViewer directly after reconstruction. Alternatively, you may load previously acquired data.
Supported file types are: .bd, .raw, .bin, .vtk.
Press the Show button on this page or the first page to start the calculation. This will take a few
seconds. Then you can view the 3D-Scan of the part in the scene. Deactivate the part or minimize the
opacity for an improved view of the 3D-Scan.
With the option Slice View → Show plane a sectional image of the part for the respectivly axis (X, Y or
Z) will appear in ImageViewer. If Show slice is activated, borders of the object can be seen in the
plane. Choose an axis and move the plane with the slider to see a sectional image of the part.

Settings for Volume View:

Minimum
Maximum
Level
Contrast
Activate/Deactivate 3D texture
Gradient/GradientROI → choose between All, Min/Max or Level/Contrast

In Positioning, the scene is affected. It is possible to position the voxel packet. With Spacing, the size
of the scene can be influenced (in X, Y, Z).
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Fig. 54: CtScan: Parameter for voluming rendering

DigRad

The DigRad module refers to the type of detector used in the simulation. For example if you want to
use a digital detector, open this module and set the parameters (Figure 55). Press Apply when
finished.

Pixel size (mm)
Basic spatial resolution SRb (mm)
Internal scatter radiation ISR (%)
ISR correlation length (mm)
Gray response (GV/mGy)
SNRn,max
Efficiency (SNRn/mGy^0.5)
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Fig. 55: DigRad calculator

ImageViewer

 The ImageViewer module is the only module that is in the docking area by default (Figure 57). It
displays the preview image and the finished simulation. You may choose between two options as
mentionend before: radiography and thickness maps (see: Compute segment in this tutorial). The
different settings and functions of ImageViewer will be explained in this chapter.

Upper bar

: A crossed out red circle means that you are currently viewing a preview of the simulation. The
preview has a lower resolution and is calculated with different parameters for faster results.

: Run  the simulation and a green tick will appear indicating that the simulation was
successful.

The drop-down menu right next to that symbol offers different views from the simulation process
(Energy density J/m² or primary intensities). The available options depend on the current settings.

The three grey fields next to the drop down menu display the mouse position (first grey field: X-axis,
second grey field: Y-axis) and the energy density [in J/m²] or primary intensities in grey value or
thickness [in mm] (third grey field) at that position. Those figures are also displayed in the status bar.

Lower bar

Display range indicates min. and max. grey value/thickness of the current image. If needed, you may
change those values with your keyboard. Press Enter when finished.

 Optimize display range (dependent on current image).

 Reset display to default range (0 - 65535).

 Display inverted to a negative of the image and back.
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 Zoom in and out with the up-down control of the spin box. Alternatively, you may use
the mouse wheel or the right mouse button. Default: Fit (zoom fits window).

 Show in actual size shows a 1:1 depiction of the current image.

 Zoom to fit window resets zoom to fit window after zooming in or out.

 Zoom to selection enlarges to a selected part of the image. Select the desired part with the left
mouse button.

Bar on the right

 Save the current image.

 Show in external viewer opens the current image in an external viewer.

 Display exposure latitude warning (de)activates warning for over- or underexposure.
Overexposed areas will be marked red, underexposed areas will be marked blue.

 Pixel for pixel mode changes between actual pixel size and screen pixel size. This option is only
active when Zoom = Fit.

 Change image orientation opens a menu with different options to mirror or rotate the image.

Fig. 56: Image View: Change image orientation

Reset is used for resetting the settings in the image orientation.

Mirror X/Mirror Y is used to reflect the image orientation on X-axis or Y-axis.

Rotate CW/Rotate CCW is used to spin the image clockwise or counter-clockwise.

0°/90°/180°/270° is used to orientate the image (between four different angles).

The same menu like in Figure 56 can be found in the Tools menu under ImageViewer → View →
Orientation. Please note that the changes made with commands from either one of those menus do
not have lasting effects, for example, when saving the image. If you want to permanently edit an
image use the commands from the following menu: Tools → ImageViewer → Image.
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 Show ruler displays a ruler on the bottom of the image.

 Show legend opens a legend with grey or thickness values. Minimum and maximum values are
determined by the display range. Height, width and position of the legend are adjustable.

Fig. 57: ImageViewer

Tools Menu: ImageViewer

In the following every command of the ImageViewer submenu from the Tools Menu (Figure 58) will be
explained.
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Fig. 58: Tools Menu, ImageViewer Menu

This submenu offers specific settings for ImageViewer and consists of different additional submenus:

File
Image
View

File

It consists of three additional submenus: Under File you can find commands to open a new image file,
save the current simulation (you may also use the Save button in ImageViewer) or clear the image list
(Figure 59).

Fig. 59: ImageViewer, File Menu

Image

Under Image you can find different filters and options to mirror or rotate the current image (Figure
60). Please note that changes made with commands from this submenu are permanent (for example
when saving the image). For non-permanent modifications use commands from the View submenu.

Fig. 60: ImageViewer, Image Menu

Filters are used to select between the filters: Gradient, Laplacian and Smooth.
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Scale is used to fill in the output values for X and Y (Figure 61). With the button next to the input

fields you can predetermine a square image  (closed symbol). If the symbol is open  the pixels
can be rectangular (by selecting different X and Y values). The Mode submenu offers specific settings.
There you can choose between linear, cubic or nearest neighbor mode. Press Cancel for quitting these
settings or OK for resampling the image.

Fig. 61: ImageViewer, Image, Scale

Mirror X/Y reflects the current image on X-axis or Y-axis.

Rotate CW/CCW spins the current image in 90 degree steps clockwise or counter-clockwise.

Math opens the ImageMath window (Figure 62). It offers several arithmetic operations and point
operations that can be applied the current image.

Fig. 62: ImageViewer, Image, Math

The first drop-down menu of the ImageMath offers the following arithmetic operations. In order for
them to work the input field for C or K has to be filled in. Except for the first two functions, MultiplyByK
and AddConstant, the actual number is not important. Press compute to run the operation and cancel
to reverse it:

MultiplyByK is used for pointwise multiplication of each pixel with K.

AddConstant is used for pointwise addition of each pixel and C.

Exp is point operator based on the exponential function and changes the dynamic range of the
image.

Log is point operator based on the log function and changes the dynamic range of the image.

Invert inverts the current picture.

AbsoluteValue takes the absolute value of each pixel.

Square squares the value of each pixel.

SquareRoot takes the square root of each pixel.

Sin calculates the sine of each pixel.
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Cos calculates the cosine of each pixel.

ATAN calculates the arctangent of each pixel.

The following operations calculate a new image out of two images therefore the third drop-down
menu is enabled. C and K may be left empty.

Add sums every corresponding pixel value of the two images.

Subtract deducts every corresponding pixel value of the second image from the first image.

Multiply multiplies every corresponding pixel value of the two images.

Divide divides every pixel value of the first image by corresponding pixel value of the second
image.

Min shows minimum grey values of the two images.

Max shows maximum grey values of the two images.

View

Under View you can find the same four mirror and rotate commands explained under Image and
additional options (Figure 63). Please note that the changes will not be visible when you save the
image or open it in an external viewer as opposed to the commands found in the Image submenu.

Fig. 63: ImageViewer, View, Orientation Menu

Interpolate activates/deactivates interpolation. aRTist uses linear interpolation.

Logarithmic is point operator based on the log function and changes the dynamic range of the
image.

Orientation is used for the following commands, which also access with this button in the

ImageViewer:  :

Reset removes all changes made in regards to orientation.
MirrorX/Y reflects the current image on the X-axis or the Y-axis.
Rotate CW/CCW spins the current image in 90 degree steps clockwise or counter-clockwise.
0°/90°/180°/270° rotates the image with four different preset values.
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McRay

McRay is a Monte Carlo raytracing implementation of electron and photon transport. This module
forms a graphical interface for McRay, in order to configure and run simulations using it from within
aRTist. If you activate the inline help icon an additional tab (Help) will appear.
In this user guide, the McRay module topics Expert, Manual, Cluster and Interactive are not being
explained.

A Run/Stop button and a progress bar are located at bottom of module window. The first four tabs
expose the configuration in order of increasing complexity.

Basic

This page contains everything necessary to run a Monte Carlo simulation with the default settings
(Figure 64). At the top there are two buttons, one to reset all settings to the default, and one to load
the images normally resulting from a successful simulation run.

Fig. 64: McRay: Basic

Options

Number of particles is used to specify the desired number of particles (photons / electrons).
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Data energy resolution is used to influence the energy resolution of these structures (by this
parameter).

Internally most material data (attenuation-coefficients, differential scatter cross-sections, etc.) is kept
in lookup structures for fast access. The default value of 1 keV does not normally need to be changed,
but for low-energy calculations, especially including fluorescence, a smaller value of e.g. 0.1 keV may
be advisable.

file prefix is used to set a project name in this field. Default name is “New”.

Output directory

Here you may change and inspect the output directory, which will hold the configuration files, data
files, and all output files (images, spectra, etc.). The four buttons at the top allow you to change the
directory via a graphical dialog, open it in an external file browser, or delete all contained files (but
not subdirectories). It is possible to reset the settings to default. You may also change the directory
by typing or pasting into the text field below the buttons.

The remaining space is filled by the file listing and associated buttons. A double click in the listing will
open the currently selected files with their associated application, as will pressing the Open button.
Show Image, Scatter Image, and TraceView will load the currently selected files in the ImageViewer
module, as the scatter image for subsequent calculations, and in the TraceView module (if installed)
respectively. The TraceView module is intended to visualize trajectories saved by McRay in the 3D
scene view. View Spectrum will attempt to pass the selected file to the included spectrum plotter.

Advanced

Simulation Options
The options on the left hand side are mostly concerned with physical effects and geometry handling.
The right hand side allows configuration of the output to produce (Figure 65).
If the command is selected it is necessary to change the number. While if the command is not
selected the default setting will be set.
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Fig. 65: McRay: Advanced

left hand side:

Photo effect considers photoabsorption when elected. Should almost always be selected.

This photoemission is the emission of electrons or other free carriers when light is shone onto a
material.

Rayleigh scattering considers Rayleigh scattering when elected.

This electromagnetic interaction is the mostly elastic scattering of light or other electromagnetic
radiation by particles (atoms or molecules) much smaller than the wavelength of the radiation.
Rayleigh scattering is a parametric process.

Compton scattering considers Compton scattering when elected.

Compton scattering occurs when the incident X-ray photon is deflected from its original path by an
interaction with an electron. The electron is ejected from its orbital position and the X-ray photon
loses energy because of the interaction but continues to travel through the material along an altered
path. Energy and momentum are conserved in this process. The energy shift depends on the angle of
scattering and not on the nature of the scattering medium. Since the scattered X-ray photon has less
energy, it has a longer wavelength and less penetrating than the incident photon.

Pair production considers pair production when elected.
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Pair production often refers specifically to a photon creating an electron-positron pair near a nucleus
but can more generally refer to any neutral boson creating a particle-antiparticle pair. In order for pair
production to occur, the incoming energy of the interaction must be above a threshold in order to
create the pair – at least the total rest mass energy of the two particles – and that the situation allows
both energy and momentum to be conserved.

Fluorescence considers flourescence when elected. Photons, and electrons if enabled, can
excite the bound electrons of the material's atoms. During relaxation fluorescence photons,
fluorescence electrons, and Auger electrons may be emitted.

Fluorescence is the emission of light by a substance that has absorbed light or other electromagnetic
radiation. It is a form of luminescence and in most cases, the emitted light has a longer wavelength,
and therefore lower energy, than the absorbed radiation.

Electron transport considers electron transport when elected. When fluorescence or
bremsstrahlung is enabled, secondary particles will be created.

The Monte Carlo method for electron transport is a semiclassical Monte Carlo (MC) approach of
modeling semiconductor transport. Assuming the carrier motion consists of free flights interrupted by
scattering mechanisms, a computer is utilized to simulate the trajectories of particles as they move
across the device under the influence of an electric field using classical mechanics. The scattering
events and the duration of particle flight is determined through the use of random numbers.

Bremsstahlung (photons) are created during electron interactions when elected and requires
electron transport.

The “braking radiation” or “deceleration radiation” is electromagnetic radiation produced by the
deceleration of a charged particle when deflected by another charged particle, typically an electron
by an atomic nucleus. The moving particle loses kinetic energy, which is converted into a photon, thus
satisfying the law of conservation of energy. The term is also used to refer to the process of producing
the radiation. Bremsstrahlung has a continuous spectrum, which becomes more intense and whose
peak intensity shifts toward higher frequencies as the change of the energy of the decelerated
particles increases.

Noninteractive starts/stops calculation without further user interaction.

Photonsplitting applies variance reduction scheme. Photonsplitting takes into account the
possible interaction process when a photon is penetrated by a medium.

Check object overlap notes the overlapping of parts when elected.

Save trajectories writes trajectory segments to disk (slow).

Target pixels aims photons toward each pixel (mostly for visualization purpose).

right hand side:

Image type is used to choose between different image types: TIFF, Isee, RAW, PGM or TXT. The
default setting is TIFF.

Pixel type is used to choose between different pixel types: UInt 16, Float, Double. Usually the
Float is used.

Pixel columns enters the number of pixel in columns.
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Pixel rows enters the number of pixel in rows.

Normalize Errors normalizes a relative error of 1 to this value (relative statistically error).

Detector model is used to choose between different detector models: aRTist, Photons, Leptons,
Electrons, Positrons or All. The default detector model is aRTist.

Scatter data registers data for this many scatter events separately.

Spectrum bins sets the number of spectrum bins. The maximum energy divide by the number of
bins reveals the spectrum for each energy.

Max threads sets the maximum number of threads.

Batch size sets the batch size of trajectories.

Random seed sets the random seed.

Execution Options
Process priority is used to adjust the process priority of the background process carrying out the
actual simulation with this parameter. You can choose between Idle, Below, Normal, Above and High.
As calculations can potentially take a long time, a reduced priority is generally advisable (default
setting: Below).

Set the Number of threads.

Help

The “Help” tab is used to get more information to some topics.

Solid

 Geometry Type
The Solid module allows you to create simple parts of different sizes to construct your assembly as
desired (Figure 66). It offers different geometric shapes to choose from:

cuboid
ellipsoid
cylinder
tube
cone
text
wedge
step wedge

Dimensions
Select the part of your choice from the drop-down menu and set the Dimensions in mm and the
Phi/Theta steps if applicable. You may predetermine equal values for X, Y and Z by checking the box
at the bottom of the module. If you choose “text” the input field at the top of the module is enabled.
When finished press the Create button.
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The default material for new parts is Fe. A list with available materials can be accessed from

the Menu Bar → Geometry → Set Material or
the Assembly List of the Parameter Panel

Fig. 66: Solid

Tomosynth

The TomoSynth module allows you to simulate tomosynthesis within aRTist (Figure 67). It consists of
two pages: the Laminography page offers settings for tube and detector position and output options.
The Advanced page offers settings that are mainly directed towards experts.

Laminography
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Fig. 67: TomoSynth: Laminography

Setup variables

Tube (S) and detector (D) can be moved on the three axes X, Y and Z. Set the parameters in the
following order:

Variable Active is used to select desired axis/axes via checkbox(es).

Distribution is used to choose a distribution out of the available options. A drop-down menu is
activated when the corresponding variable is selected. Deterministic and random distributions are
available. A deterministic distribution is a mathematical formula, which describes how to compute the
value for a given image number step for a total of Nsteps images. Here, step varies from 0…Nsteps-1.
A random distribution assigns a (pseudo-)random number with a given probability density to the
associated variable. The pseudorandom numbers are generated by hashing sequence numbers with a
fixed random seed and therefore are completely reproducible.

Please note that the sign of the radius (circle, arc, disc) defines the orientation of the rotation, where
positive radius values indicate a right-handed rotation.

Deterministic distributions:

linear is used to increase/decrease linear from from to to.

logarithmic is used to increase/decrease logarithmic from from.

constant sets a variable to a constant value. Most useful to define the axis of rotation for
rotating objects.

circle_x revolves in X-direction.

circle_y revolves in Y-direction.

arc_x is used to calculate arc in X-direction.

arc_y is used to calculate arc in Y-direction.
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disc_x is used to disc in X-direction.

disc_y is used to disc in Y-direction.

formula_rnd is used to make a formula with a random variable.

formula is used to enter an arbitrary mathematical formula to define a deterministic
distribution. The expression is evaluated using the rules of expr of the Tcl scripting language.
For a detailed reference, please consult the online documentation for Tcl here.

Random distribution:

uniform

gaussian

lognormal

Parameters are used to fill in the values of activated parameters.

Preview  is used to see a preview in ImageViewer of the tube's and/or
detector's movement for the current settings when moving the slider (if checkbox is activated).
Beneath the settings for tube and detector, you can find a slide control next to the preview checkbox.

Output options

choose a Format from the following options: RAW, TIFF, TIFF 16bit and FLD 16bit
put in a File name
put in the Number of steps
choose Output directory

Alternatively, you may use the default settings.

When finished press the Run button to start the simulation or Reset if you wish to discard the changes
you have made.

Advanced

The settings in this tab are mainly directed towards experts (Figure 68).

http://www.tcl.tk/man/tcl8.6/TclCmd/expr.htm#M22
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Fig. 68: TomoSynth: Advanced

Protocol
It is possible to change the settings for each part of the scene.

Variable Active selects desired axis/axes via checkbox(es).

Distribution is used to choose a distribution from the available options. A drop-down menu is
activated when the corresponding variable is selected. Please note that the sign of the radius (circle,
arc, disc) defines the orientation of the rotation, where positive radius values indicate a right handed
rotation.

Parameters are used to fill in necessary parameters.

Rotation Angle sets the rotation angle, the polar angle theta, and the azimuthal angle phi.

Position Shift sets the position shift in the three axes: Δx, Δy and Δz.

Size Scale sets the size scale in the three axes: Sx, Sy and Sz.

Tube parameters

Current drop-down menu is activated when “Current” is selected. Choose a distribution from the
available options (linear, logarithmic, constant, circle_x, circle_y, arc_x, arc_y, uniform, gaussian,
lognormal, disc_x, disc_y, formula_rnd or formula).

Voltage drop-down menu is activated when “Voltage” is selected. Choose a distribution from the
available options (linear, logarithmic, constant, circle_x, circle_y, arc_x, arc_y, uniform, gaussian,
lognormal, disc_x, disc_y, formula_rnd or formula).
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Preview is used to see a preview in ImageViewer. Beneath the settings for tube and detector you can
find a slide control next to the preview checkbox. Activate the checkbox and move the slider to see a
preview of the tube's and/or detector's movement for the current settings.

Output options

choose a Format from the following options: RAW, TIFF, TIFF 16bit and FLD 16 bit
put in a File name
put in the Number of steps
choose Output directory
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Tools

In this chapter the following tools of the Menu Bar are being explained: Attenuation Data, Detector
Properties, Materials, Spectrum and Settings.

Attenuation Data

The AttenuationViewer shows the attenuation-coefficient as a function of the radiation's energy
(Figure 69). It consists of different graphs:

photo effect
incoherent scattering
coherent scattering
pair production
total

: The displayed data can be saved in tabulated, or graphical form (see Icon).

Fig. 69: AttenuationViewer

Detector Properties

The DetectorViewer contains plots of the properties of the current detector (Figure 70):

Characteristic is used for grey values, film densities or air dose mGy as a function of energy
density J/m²

Noise is used for SNR as a function of energy density

Sensitivity deposits energy as a function of energy
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The type of graph(s) available is dependent on the detector.

On the left-hand side of DetectorViewer details of the current detector are displayed:

Name
Input unit
Output unit
Pixel count
Pixel size [mm]
Resolution [mm]
Long range unsharpness [mm]
Long range contribution [%]
Minimum output
Maximum output
Output quantum
Target exposure

Fig. 70: DetectorViewer

Materials

 The Materials editor lists all materials that are available within aRTist including density and
composition (Figure 71). You may dock the editor in the docking area.
It provides the following possibilities to edit materials:

Edit selected material. Click on an entry you wish to edit, for example density or composition.
Press enter when finished.

 Add is used to append a new material definition.
 Delete is used to erase currently selected material.
 Edit display is used to revise material display parameters for currently selected material.
 Attenuation plots attenuation data for currently selected material.

Apply is used to update material database with table contents.
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Refresh is used to reload table contents from material database.

Please note: Densities are given in g/cm³. The composition must be of the form: H2O 0.96 NaCl 0.04.
The fractional numbers are mass ratios.

Fig. 71: Materials editor

Spectrum

The Spectrum calculator offers specific settings for the source (Figure 73). It can also be opened from

the Parameter Panel → Source: . You may dock the Spectrum calculator in the docking area.

Settings

Set

Tube (choose between Mono or General)
voltage [kV]
resolution [keV]
filter material and thickness [mm], (pick VOID as a material if you do not want to use a filter)

 Load tube definitions, File type: .dict.
 |  Save tube definition (hold or right-click for options) or delete tube definition from database.

Tube Settings
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If you choose the general tube type an advanced setting will appear. There you can set:

Name |  (add tube definition to database)
Maximum voltage [kV] (optional)
Maximum current [mA] (optional)
Maximum power [W] (optional)
Transmission (enable/disable transmission)
Target material (choose between Al, Be, Cu, Fe, Mg, Mo, Ni, Pb, Pt, Ti, W, air, water or VOID)
Target thickness [mm]
Target angle [deg]
Angle of electron incidence [deg]
Window material (choose between Al, Be, Cu, Fe, Mg, Mo, Ni, Pb, Pt, Ti, W, air, water or VOID)
Window thickness [mm]

Under Tube Settings you can set maximum values for the tube and adjust the target material,
thickness and angle, the angle of electron incidence and the window material and thickness. Mark the
Show principle checkbox in the bottom row and a schematic drawing appears which shows the
principle of the simulated tube. Press the Compute button in the lower part of the window to apply
changes when finished.

If the tube voltage is set over 128 keV, a window will appear with the note: “This spectrum contains
(146) entries, the currently recommended value is 128. Reduce?” You can choose between Yes or No.
→ By selecting Yes, you can see a reduced spectrum at the Source → Source spectrum. Keep holding

the left-click on the mouse or right-click the symbol . There you can open “Show reduced
spectrum”, “Show reduced spectrum” or “Show prewiew spectrum” to see the different spectrums
(Figure 72).

Fig. 72: Spectrum selection

→ By selecting No, the spectrum is not reduced and will stay as the original spectrum.
If needed, it is possible to change the number of reduced spectrums bin at Tools → Settings →
Advanved.

http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Atools&media=artist:spec.png
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Fig. 73: Spectrum calculator

Settings

Settings
The Settings dialog box offers several options to adjust the user interface (Figure 74).
Set

Number of last open files
Default directory
License file
External viewer
Background color
GUI style *: Choose between small, normal or large.
Dock position: Choose between right, left, bottom or top.
Display invicible parts: Choose between gray, alpha, keep or off.
Stereo mode: Choose between Anaglyph, CristalEyes, Interlaced or Checkerboard.
Anaglyph color mask: Choose between red/cyan, red/green, red/blue, yellow/blue or
green/magenta.
Decimate objects larger than [kB]

enable/disable
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Use decimated geometry for preview
Show scene view info in status bar
Show radiograph in 3D view
Prefer GPU computing
Single precision results

Press OK for saving or Cancel for quitting these settings. The changes are effective after program
restart.

Fig. 74: Settings

Advanced
Advanced settings should normally not be changed (Figure 75, 76 and 77).
aRTist: Set

Log level: Choose between Info, Error, Warn, Verbose, Debug, Trace or Off. The default setting
is Info.
Computibility working directory

Geometry: Set

Number of triangles in decimated geometry

Enable/disable:

Double precision coordinates
Triangle strips

GUI: Enable/disable
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Pick disabled parts
Show orientation marker
Animate view transitions
Use bounding box level of detail

Set:

Anti-aliasing frames
Multisampling
Max depth peels
Maximum render time [s]

Engine: Set

Number of reduced spectrum bins
Number of preview spectrum bins

Enable/disable

Check for object overlap
Use AVX2
Use FMA
Use AVX
Use SSE2
Use generic vector extensions
Single precision intermediated
Single call GPU calculations
Single pass GPU calculations
Half percision GPU calculations

Remote Control: Enable/disable

Accept connections

Set

Address to listen on
Port to listen on
Maximum increment when port in use

Scatter: Set

Smoothing anisotropy
Smoothing strength

Press OK for saving or Cancel for quitting these settings. It is possible to Reset the settings on default.
The changes are effective after program restart.
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Fig. 75: Settings, Advanced I
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Fig. 76: Settings, Advanced II

Fig. 77: Settings, Advanced III
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Geometry Manipulation

In the following you will find a more in-depth explanation for “Geometry Manipulations” (Union,
Intersection, Difference, Arrange and Pick Destination) from the Menu Bar → Geometry drop-down
menu. With the contained commands, which are the red edged ones in Figure 78, individual parts in
the assembly can be created and arranged.

Fig. 78: Geometry Manipulation, red edged

Union/Intersection/Difference: These commands can be used to create more complicated shapes
than simple geometric parts like cuboids or cylinders. First, generate the parts you need with the help

of the Solid module. This module can also be opened with its tool bar icon . Translate, scale or
rotate the parts as needed so that they overlap. Then select parts by using the Ctrl key on your
keyboard and click on them with the left mouse. The first selected part can be recognized by its
yellow corners. All subsequent parts will be marked with white corners. If the parts consist of different
materials, the new created part will take over the same material as the first selected part.
The effect of each of the three commands is shown in the following pictures:

Union: This command joins two or more parts as depicted in Figure 79. The order of selection is not
important.

Fig. 79: Union (right) of two cubic parts (left)

http://ws1569.zit.bam.de/dokuwiki/lib/exe/detail.php?id=artist%3Ageometry_manipulation&media=artist:geomneuu.png
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Intersection: This command generates a part from the overlapping areas. Everything else is
removed as shown in Figure 80. Thereby the order of selection is not important.

Fig. 80: Intersection (right) of two cubic parts (left)

Difference: This command generates a new part from the difference of at least two other parts. In
this case, the order of selection will be important for the result as shown in Figure 81 and Figure 82.
The first selected part (yellow corner) is thereby the minuend and all other selected parts (white
corners) are the subtrahends.

Fig. 81: Difference (right) of cuboid minus ellipse (left)

Fig. 82: Difference (right) of ellipse minus cuboid (left)

 Arrange: This option allows you to arrange parts of your assembly. Select the parts you want to
arrange (use the Ctrl key on your keyboard) and open the Arrange dialog box with the tool bar icon or
with the Arrange command in the Geometry menu. There are four options: none, -, center, + available
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for each of the three axes (X, Y, Z). Choose one or more of these options and press either the Apply or
the OK button.

Apply lets you see the changes you have made and undo them if needed.
OK applies the changes and closes the dialog box.
Cancel closes the dialog box without changing the assembly.

Please note: The parts will be aligned with the first selected part which can be recognized by its
yellow corners.

The following pictures show the effect of the Arrange function on the three parts shown in Figure 83.

Fig. 83: Arrange

Y-axis

Figure 84 shows the three parts arranged on the Y-axis as an example. - and + align them with the
edges of the light violet cuboid. Center centers the parts on the Y-axis.
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Fig. 84: FLTR: -, center, +

Pick Destination: This command moves parts from one point in the scene view to another point.
Mark one or more parts from your assembly and select the command. A grey cross will appear while
hovering over the scene view with the mouse cursor. Click on desired destination to relocate selected
part(s).
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Change Log

aRTist 2.12.6
CHG: McRay/TraceView: use binary files to store traces by default
CHG: Spectrum calculator: improved tube handling
CHG: Spectrum calculator: fix read-in from project file of possible second and third filters
CHG: minor fixes

aRTist 2.12.5
CHG: Table2Lists: change separators to “, ;\t”
CHG: Materials: change comment of default materials to indicate “preset of aRTist”
CHG: CtScan 2.7: rename scatter modes to “as configured” and “force McRay”
CHG: Library: Dragon-CT project with flat field correction enabled

aRTist 2.12.4
FIX: BAMCT writer: fix nw180 in header
CHG: Detector MTF improved (experimental)
CHG: Module manager: add delete button for user installed modules

aRTist 2.12.3
New: Online guide at help menu
New: Detector MTF (experimental)
New: CtScan postprocessing (experimental)
CHG: Spectrum calculator: two additional filters
CHG: minor fixes

aRTist 2.12.1
Fix: Licenser: checking if network folder is writable
CHG: McRay: save scene/spectrum/geometry inside the task configuration

aRTist 2.12
FIX: Detector unsharpness matches MTF-10 basic spatial resolution (Duplex Wire iSRb,
ASTM E 2002).
CHG: Licenser: grand a goodwill period, if license file is temporary unavailable
CHG: minor GUI fixes
switch version control from Svn to Git

aRTist 2.10.4
NEW: Settings/Advanct option: default material
CHG: DetectorCalc: Save settings in detector file.
CHG: Spectrum picker: make incident spectra optional

aRTist 2.10.2/3
CHG: Improoved license dialog.
CHG: Licenser: Lite mode, if out of network licenses

aRTist 2.10.1
NEW: TomoSynth: new distribution type “list”
CHG: parts of material “None” will be ignored by the tracer (scene visualization only)
CHG: revised dialog for license information and activation
CHG: indroducing version numbers for modules
CHG: minor fixes
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aRTist 2.10
CHG: McRay updated
…
CHG: updated copy protection, new license files required

aRTist 2.8.3
NEW: module DetectorCalc
CHG: minor fixes

aRTist 2.8.2
CHG: DigRad and DetectorCalc, extend noise curve
CHG: McRay, use full spectrum instead of reduced
CHG: McRay, fix/improve opening angle calculation
CHG: Scattering: improve reduced detector resolution for McRay
CHG: minor fixes and GUI improvements

aRTist 2.8.1
CHG: BAM logo
CHG: minor GUI improvements

aRTist 2.8.0
CHG: McRay, improve smoothing of scatter image
CHG: McRay, minor model improvements
NEW: Solid, add creation of (step) wedges
CHG: improve PDF export of graphs
NEW: TomoSynth/SimuPOD, allow (user) control over number of random samples
NEW: Image, allow reading 3D FLDs
CHG: FileIO, attempt material selection when loading known IQI
NEW: allow loading TCL scripts (sourced in namespace External)
CHG: update Tcl/Tk to 8.6.2
CHG: make orientation marker visibility configurable
CHG: improve preview geometries
CHG: add multisampling/anti-aliasing options to settings dialog (advanced tab)
CHG: minor GUI improvements

aRTist 2.6.3
CHG: XSource, fix/improve creation of focal spot profiles
CHG: CtScan, enable GPU reconstruction by default
BUG: Solid, clean generated polygon data
BUG: minor bug fixes

aRTist 2.6.2
Special Version for MINTec

aRTist 2.6.1
Special Version for Saclay Fall School
BUG: program crash

aRTist 2.6.0
date: 2014-06-19
CHG: restructure menu bar and other GUI revisions
CHG: ray-cast engine updated
NEW: indicate modifications in title bar
NEW: experimental OS X version
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CHG: XRayTools updated
CHG: McRay updated
CHG: PODTool updated (optional)
CHG: show unreduced spectra
CHG: update ISee!-demo to v1.11.1
BUG: minor bug fixes

aRTist 2.4.2
BUG: fix normalization of source grid with focal spot image

aRTist 2.4.1
CHG: new license files

aRTist 2.4.0
date: 2013-07-01
NEW: include 64bit version
NEW: crash recovery
BUG: fix a memory leak in CT scan with TIFF output
NEW: use AVX2/FMA/AVX processor extension if available
NEW: better handling of unsaved changes
CHG: div. improvements in Monte-Carlo scatter module
CHG: improve/extend POD calculations

aRTist 2.2.0
date: 2012-09-06
New: McRay scatter mode
CHG: CtScan with new Feldkamp implementation
NEW: CtScan with volume viewer
CHG: GUI improvements
NEW: more IQI geometries

aRTist 2.0.0
date: 2012-02-23
CHG: major code refactoring
CHG: new Bremsstrahlung spectra model (XRayTools)
CHG: reimplementation of the ray casting engine
CHG: GUI redesign
NEW: 3D view mouse interaction
NEW: live preview
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